Sunday, 1 April 2012

Unexpected progress

Yesterday the decoder was fitted and it worked, for a whole 60 seconds! Typical progress it felt like. Today, under a magnifier I realised that I could see more of the commutator than I should. I hadn't pushed home one of the brush clips as far as I should have. Once I solved that I was able to drive the loco round the layout. There's a couple of dodgy points but I think that's a left over from how they were previously wired. I can fix that another day.

Time to try something new. Plug in the USB interface for the computer. Even that worked. I was able to read the decoder and store it's parameters on the laptop and also control the loco from the laptop. An amazing amount of success so the question is - should I push my luck and try something else new?

video

With JMRI there is a feature called the WiThrottle Server. This turns the laptop into a server to allow other devices to control the layout over the home wifi. Someone has written an application for the Android SmartPhone to do just that. I started the WiThrottle server and allowed it through the firewall when prompted. After that the app on the phone detected that a server was available and I just said 'connect' and this video was the result. Apologies for the quality but the light was not good. However, the numbers on the screen are the speed of the loco.

You cannot do this at an exhibition, I don't think, as it relies on a wifi connection and really it is a bit of a gimmick but it was surprisingly easy to set up.